Service requests are loading slow in manager.
Incident Report for iRiS Software Systems Ltd
Resolved
This incident has been resolved.
Posted about 2 months ago. May 25, 2019 - 13:10 UTC
Identified
Some users may experience loading times in excess of 30 seconds when listing service requests in manager.

The Development team have found the cause and are working on a fix.

Once the fix is completed a decision will be made on when this will be applied. Further updates will be posted here in due course.
Posted 2 months ago. May 16, 2019 - 09:57 UTC
This incident affected: Manager.