Guest API service unavailable

Incident Report for IRIS Software Systems Ltd

Resolved

This issue has now been resolved.

We would like to take this opportunity to apologise for any inconvenience that this may have caused. If you are still experiencing difficulties, please contact the support team at support@iris.net or +44 203 322 5690 for assistance.
Posted Apr 01, 2026 - 09:36 BST

Update

The Guest API service is now not seeing any further issues and is considered resolved. We continue to monitor the Manager API, and the permanent fix for this service will be in place later today.

The team will continue to monitor closely for the next 12hrs.

Next update: 12:00 UTC (Tuesday, 31st of March)
Posted Mar 31, 2026 - 10:18 BST

Monitoring

We have now put in place a solution to resolve the issue caused by API Service layer. All services are now operational and should now return to normal.
The team will continue to monitor closely for the next 12hrs.

Next update: 8:00 UTC (Tuesday, 31st of March)
Posted Mar 30, 2026 - 20:41 BST

Investigating

We have no further information at this moment. The team continue to investigate the problem and as soon as an update becomes available we will update this thread.

Workaround: In parallel, we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having been updated with the current configuration.

This Workaround is not available for Guest Room, which may continue to experience the issue.

Next update: 20:00 UTC
Posted Mar 30, 2026 - 20:07 BST

Update

The engineering team are still investigating the issue. At this time, we do not have any timescales on when this problem will be resolved. Every effort is being made to provide a solution as quickly as possible.

Workaround: In parallel, we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having been updated with the current configuration.

This Workaround is not available for Guest Room, which may continue to experience the issue.

Next update: 19:00 UTC
Posted Mar 30, 2026 - 19:09 BST

Update

The engineering team are still investigating the issue. At this time, we do not have any timescales on when this problem will be resolved. Every effort is being made to provide a solution as quickly as possible.

Workaround: In parallel we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having updated with the current configuration.

This Workaround is not available for Guest Room, which may continue to experience the issue.


Next update: 18:00
Posted Mar 30, 2026 - 18:09 BST

Update

We have no further information at this moment. The team continue to investigate the problem and as soon as an update becomes available, we will update this thread.

Workaround: In parallel we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having updated with the current configuration.

This Workaround is not available for Guest Room, which may continue to experience the issue.

Next update: 15:00 UTC
Posted Mar 30, 2026 - 16:05 BST

Update

The engineering team continue to work with Microsoft to resolve the API layer issue. This is still ongoing and continuing to affect the Manager API.

Workaround: In parallel, we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having updated with the current configuration.

This Workaround is not available for Guest Room, which may continue to experience the issue.

Next update: 14:00 UTC
Posted Mar 30, 2026 - 15:11 BST

Update

The engineering team continue to work with Microsoft to resolve the API layer issue. This is still on going.

Workaround: In parallel we have been able to create a temporary API Layer, and all properties should be available again now with the CDN service having updated with the current configuration.

This Workaround is not available for Guest Room which may continue to experince the issue.

Next update: 14:00 UTC
Posted Mar 30, 2026 - 14:06 BST

Update

We are continuing to work on a fix for this issue.
Posted Mar 30, 2026 - 12:50 BST

Identified

The engineering team have identified the cause of the issue to be caused by a failure in the Microsoft API layer service and we are working with Engineers to resolve the issue.

Workaround: In parallel we have been able to create a temporary API Layer with another service and expect the service to be available again in the next 20-30 mins as the CDN's update their cache.

This Workaround is not available for Guest Room which may continue to experince the issue.

Next update: 13:00 UTC
Posted Mar 30, 2026 - 12:49 BST

Investigating

We are currently experiencing a failure of the Guest API service due to an issue with our Vendor API layer. Guests will not be able to view the menu and will be presented with a blank view.
Our engineering team are working with our vendor to investigate the issue, and we expect an update in the next hour.

Services affected: Guest Mobile / Web

Workaround: There is no work around as this present time.

Next update: 12:30 UTC
Posted Mar 30, 2026 - 12:26 BST
This incident affected: Manager, Manager API and IRIS Guest (Web, Mobile, Room).