Degraded performance to API Services
Incident Report for iRiS Software Systems Ltd
Resolved
This issue has now been resolved
Posted Dec 04, 2023 - 12:26 GMT
Monitoring
We have now put in place a solution to resolve the issue caused by a problem with a certificate with one of our services. All services are now operational and should now return to normal. There may be some slow page loads while the cache rebuilds across all the regions but this should be completed in the next 20-30minutes.
The team will continue to monitor closely for the next 24hrs.
Posted Dec 02, 2023 - 17:56 GMT
Identified
The engineering team have identified the cause of the issue with the web services and are currently working on implementing the resolution.

Workaround: None at present

Next update: 18:00
Posted Dec 02, 2023 - 17:28 GMT
Update
We have no further information at this moment. The team continue to investigate the problem and as soon as an update becomes available we will update this thread.

Workaround: [place details of any workaround available/ No workaround available]

Next update: 18:00 GMT
Posted Dec 02, 2023 - 17:06 GMT
Investigating
We are currently experiencing a degraded performance with the API Service. Our engineering team are investigating, and we expect an update in the next hour.

Services affected: Guest Mobile / Room / Web / Manager API

Workaround: none

Next update: 5.00pm GMT
Posted Dec 02, 2023 - 16:36 GMT
This incident affected: Manager, Manager API and CMS API (Europe, Nort America East, South East Asia).