Slow email delivery

Incident Report for iRiS Software Systems Ltd

Resolved

This incident has been resolved.
Posted Mar 13, 2019 - 15:32 GMT

Monitoring

One of our providers have notified us that email delivery may delayed by up to 15 minutes. This will affect password reset emails and notifications.

The SMS and Voice channels remains unaffected.

We have been advised that this may last until 15:00 UTC
Posted Mar 13, 2019 - 12:16 GMT
This incident affected: Notifications (Email).